読者です 読者をやめる 読者になる 読者になる

Webサイト専門プログラマの言いたい放題

元システムエンジニアがサイト制作とプログラミングについて好き放題しゃべります。

【パトラッシュ・・・】

f:id:wp-lesson:20170411142301j:plain

結局、IE8互換対応の先陣を
切ることになりました。
 
 
「互換用のjsプラグイン
 いろいろ転がってるから、
 簡単に対応できるだろ?」
 
 
とかすぐに言いたがる
現場を知らないエンジニアに
言ってやりたい。
 
 
『じゃあアナタがやれば?』
『簡単なんでしょ?』
 
 
と。
  
 
互換用のjsプラグインは、
バンソーコーのようなもので、
万能薬ではありません。
 
 
HTML5に(ある程度)対応させるもの
・CSS3に(ある程度)対応させるもの
・メディアクエリに(ある程度)対応させるもの

 
 
誰も彼も、(ある程度)って部分を
読み飛ばしているように感じます。
 
  
「これさえ読み込めば100%対応だ!」
 
 
なんて過信し過ぎです。
自分が解釈したいように解釈してるだけ。
ご都合主義なんでしょうかね?
 
 
なぜプラグインという言葉を
魔法のように妄信するんだろう。 
 
 
サイトポリシーが「IE8以上」っていう
後から要求が出てきて対応するなんて
久しぶりのことです。
 
 
疲れたよパトラッシュ
 
 
いつの間にか夜中か。
お風呂入ってネロっと。
 
 
ダジャレが決まったので安眠できそう。